<!doctype html>
<html>
    <head>
        <meta charset="utf-8" />
        <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
        <link rel="stylesheet" type="text/css" href="https://app.gitbook.com/public/emojis/emoji-assets-sprite.css?v=10.0.15-eda761893f18a9c82baefa53b70d3e24fc50bc09-1385309814" media="all" />
        <style>
            html, body {
                -webkit-font-smoothing: antialiased;
                text-rendering: optimizelegibility;
                width: 100%;
                height:100%;
                overflow: hidden;
                user-select: none;
                outline: none;
            }
            body.dragging * {
                cursor: grabbing !important;
            }
            * {
                box-sizing: border-box;
            }
            *:focus, *:hover {
                outline: none;
            }
            #root, #splashscreen { position: fixed; top:0; right: 0; bottom: 0; left: 0; display:flex; width: 100%; height:100%; }
            .slate-spacer {
                height: 0;
                color: transparent;
                outline: none;
                position: absolute;
            }
            @keyframes LoadingIndicator {
                from { transform: rotate(0deg); }
                to { transform: rotate(360deg); }
            }
            [data-loading-indicator="true"] {
                animation: LoadingIndicator 0.6s ease infinite;
            }
        </style>
        <title>Welcome - Sockpuppet</title>
<link rel="preload" as="font" type="font/woff2" href="https://app.gitbook.com/public/fonts/Roboto/Roboto-Bold.woff2?v=3.19" crossorigin="anonymous">
<link rel="preload" as="font" type="font/woff2" href="https://app.gitbook.com/public/fonts/Roboto/Roboto-BoldItalic.woff2?v=3.19" crossorigin="anonymous">
<link rel="preload" as="font" type="font/woff2" href="https://app.gitbook.com/public/fonts/Roboto/Roboto-Black.woff2?v=3.19" crossorigin="anonymous">
<link rel="preload" as="font" type="font/woff2" href="https://app.gitbook.com/public/fonts/Roboto/Roboto-BlackItalic.woff2?v=3.19" crossorigin="anonymous">
<link rel="preload" as="font" type="font/woff2" href="https://app.gitbook.com/public/fonts/Roboto/Roboto-Medium.woff2?v=3.19" crossorigin="anonymous">
<link rel="preload" as="font" type="font/woff2" href="https://app.gitbook.com/public/fonts/Roboto/Roboto-MediumItalic.woff2?v=3.19" crossorigin="anonymous">
<link rel="preload" as="font" type="font/woff2" href="https://app.gitbook.com/public/fonts/Roboto/Roboto-Regular.woff2?v=3.19" crossorigin="anonymous">
<link rel="preload" as="font" type="font/woff2" href="https://app.gitbook.com/public/fonts/Roboto/Roboto-Italic.woff2?v=3.19" crossorigin="anonymous">
        <style id="__gitbook-content-font">
            @font-face {
            font-family: 'gitbook-content-font';
            font-style:  normal;
            font-weight: 700;
            font-display: swap;
            src: local("Roboto Bold"), local("Roboto-Bold"), url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Bold.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Bold.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-content-font';
            font-style:  italic;
            font-weight: 700;
            font-display: swap;
            src: local("Roboto BoldItalic"), local("Roboto-BoldItalic"), url("https://app.gitbook.com/public/fonts/Roboto/Roboto-BoldItalic.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/Roboto/Roboto-BoldItalic.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-content-font';
            font-style:  normal;
            font-weight: 800;
            font-display: swap;
            src: local("Roboto Black"), local("Roboto-Black"), url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Black.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Black.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-content-font';
            font-style:  italic;
            font-weight: 800;
            font-display: swap;
            src: local("Roboto BlackItalic"), local("Roboto-BlackItalic"), url("https://app.gitbook.com/public/fonts/Roboto/Roboto-BlackItalic.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/Roboto/Roboto-BlackItalic.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-content-font';
            font-style:  normal;
            font-weight: 500;
            font-display: swap;
            src: local("Roboto Medium"), local("Roboto-Medium"), url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Medium.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Medium.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-content-font';
            font-style:  italic;
            font-weight: 500;
            font-display: swap;
            src: local("Roboto MediumItalic"), local("Roboto-MediumItalic"), url("https://app.gitbook.com/public/fonts/Roboto/Roboto-MediumItalic.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/Roboto/Roboto-MediumItalic.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-content-font';
            font-style:  normal;
            font-weight: 400;
            font-display: swap;
            src: local("Roboto Regular"), local("Roboto-Regular"), url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Regular.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Regular.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-content-font';
            font-style:  italic;
            font-weight: 400;
            font-display: swap;
            src: local("Roboto Italic"), local("Roboto-Italic"), url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Italic.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/Roboto/Roboto-Italic.woff?v=3.19") format("woff");
        }
        </style>
<meta name="description" content="Build reactive applications with the Django tooling you already know and love" id="__meta-description" />
<meta name="og:description" content="Build reactive applications with the Django tooling you already know and love" id="__meta-og:description" />
<meta name="og:image" content="https://app.gitbook.com/share/space/thumbnail/-M7RbxeoKTD04ZBTrmC5.png?color=%23F77D05&logo=&theme=none" id="__meta-og:image" />
<meta name="twitter:card" content="summary" id="__meta-twitter:card" />
<link rel="icon" href="https://app.gitbook.com/public/emojis/1f58b.png?v=6.0.0"  id="__link-icon" />
<meta name="og:title" content="Welcome" id="__meta-og:title" />
<meta name="twitter:site" content="Sockpuppet" id="__meta-twitter:site" />
<meta name="robots" content="index" id="__meta-robots" />

        <style>
            @font-face {
            font-family: 'gitbook-code-font';
            font-style:  normal;
            font-weight: 700;
            font-display: swap;
            src: local("Source Code Pro Bold"), local("SourceCodePro-Bold"), url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Bold.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Bold.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-code-font';
            font-style:  italic;
            font-weight: 700;
            font-display: swap;
            src: local("Source Code Pro BoldItalic"), local("SourceCodePro-BoldItalic"), url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-BoldItalic.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-BoldItalic.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-code-font';
            font-style:  normal;
            font-weight: 800;
            font-display: swap;
            src: local("Source Code Pro Black"), local("SourceCodePro-Black"), url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Black.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Black.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-code-font';
            font-style:  italic;
            font-weight: 800;
            font-display: swap;
            src: local("Source Code Pro BlackItalic"), local("SourceCodePro-BlackItalic"), url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-BlackItalic.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-BlackItalic.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-code-font';
            font-style:  normal;
            font-weight: 500;
            font-display: swap;
            src: local("Source Code Pro Medium"), local("SourceCodePro-Medium"), url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Medium.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Medium.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-code-font';
            font-style:  italic;
            font-weight: 500;
            font-display: swap;
            src: local("Source Code Pro MediumItalic"), local("SourceCodePro-MediumItalic"), url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-MediumItalic.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-MediumItalic.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-code-font';
            font-style:  normal;
            font-weight: 400;
            font-display: swap;
            src: local("Source Code Pro Regular"), local("SourceCodePro-Regular"), url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Regular.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Regular.woff?v=3.19") format("woff");
        }
@font-face {
            font-family: 'gitbook-code-font';
            font-style:  italic;
            font-weight: 400;
            font-display: swap;
            src: local("Source Code Pro Italic"), local("SourceCodePro-Italic"), url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Italic.woff2?v=3.19") format("woff2"),
                    url("https://app.gitbook.com/public/fonts/SourceCodePro/SourceCodePro-Italic.woff?v=3.19") format("woff");
        }
        </style>
        <style id="react-native-stylesheet">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</style>
    </head>
    <body>
        <div id="root"><div class="css-1dbjc4n r-13awgt0 r-12vffkv" data-reactroot=""><div class="css-1dbjc4n r-13awgt0 r-12vffkv"><div data-rnw-media-class="visible__hidden" class="css-1dbjc4n"><div data-rnw-media-class="1502__1503" class="css-1dbjc4n r-1awozwy r-14lw9ot r-1d9grui r-qklmqi r-4dj0k7 r-1quu1zo r-18u37iz r-184en5c"><div aria-label="Show Table of Content" data-rnw-media-class="visible__hidden" data-rnw-int-class="180073___694_" tabindex="0" class="css-1dbjc4n r-1awozwy r-42olwf r-18c69zk r-rs99b7 r-1bnj018 r-1loqt21 r-18u37iz r-18kxxzh r-eu3ka r-1777fci r-1kb76zh r-1ny4l3l r-mk0yit r-1otgn73 r-1i6wzkk r-lrvibr r-1aockid" style="-webkit-transition-duration:0s;transition-duration:0s"><svg viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" preserveAspectRatio="xMidYMid meet" data-rnw-int-class="180074___696_" class="r-h7gdob" style="height:18px;vertical-align:middle;width:18px"><path d="M3 12h18M3 6h18M3 18h18"></path></svg></div><a href="/" data-rnw-int-class="180086____" data-rnw-media-class="1500-95-196__7mwae0-123-197" class="css-4rbku5 css-1dbjc4n r-1awozwy r-1loqt21 r-18u37iz r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s" data-testid="public.headerHomeLink"><div class="css-1dbjc4n r-1awozwy r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2 r-1h0z5md r-6wscbn"><div class="css-1dbjc4n"><div data-rnw-media-class="hidden__visible" class="css-1dbjc4n"><div class="css-1dbjc4n r-1awozwy r-14lw9ot r-z2wwpe r-1l94q7l r-18u37iz r-eu3ka r-1777fci r-88pszg r-1aockid" style="overflow-x:hidden;overflow-y:hidden"><div class="css-1dbjc4n r-4qtqp9 r-1q9jyb7 r-1oec5bt r-u8s1d" style="height:80px;width:80px"><span class="emj-objects _1f58b" role="img" title="fountain pen" aria-label="fountain pen" style="transform:translate(-50%, -50%) scale(1.25)">🖋</span></div><div class="css-1dbjc4n r-4qtqp9 r-bnwqim" style="height:28.16px;width:28.16px"><span class="emj-objects _1f58b" role="img" title="fountain pen" aria-label="fountain pen" style="transform:translate(-50%, -50%) scale(0.44)">🖋</span></div></div></div><div data-rnw-media-class="visible__hidden" class="css-1dbjc4n"><div class="css-1dbjc4n r-1awozwy r-14lw9ot r-z2wwpe r-1l94q7l r-18u37iz r-1777fci r-88pszg" style="height:24px;overflow-x:hidden;overflow-y:hidden;width:24px"><div class="css-1dbjc4n r-4qtqp9 r-1q9jyb7 r-1oec5bt r-u8s1d" style="height:48px;width:48px"><span class="emj-objects _1f58b" role="img" title="fountain pen" aria-label="fountain pen" style="transform:translate(-50%, -50%) scale(0.75)">🖋</span></div><div class="css-1dbjc4n r-4qtqp9 r-bnwqim" style="height:16.64px;width:16.64px"><span class="emj-objects _1f58b" role="img" title="fountain pen" aria-label="fountain pen" style="transform:translate(-50%, -50%) scale(0.26)">🖋</span></div></div></div></div><div dir="auto" data-rnw-media-class="227__226" class="css-901oao"><span aria-label="Sockpuppet" data-rnw-int-class="180087_243__257-48040_" class="css-901oao css-16my406 css-vcwn7f">Sockpuppet</span></div></div></a><div data-rnw-media-class="hidden__visible" class="css-1dbjc4n" style="margin-left:-1px"></div><div data-rnw-media-class="_visible_hidden" class="css-1dbjc4n r-1awozwy r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2"></div><div data-rnw-media-class="_hidden_1501" class="css-1dbjc4n r-1awozwy r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2"></div><div data-rnw-media-class="hidden__visible" class="css-1dbjc4n" style="margin-right:-1px"></div><div data-rnw-media-class="1500__1kbfcbz" class="css-1dbjc4n"><div class="css-1dbjc4n r-1habvwh r-1ro0kt6 r-16y2uox r-1wbh5a2 r-puj83k r-1pyaxff"><div data-rnw-media-class="hidden__visible" class="css-1dbjc4n"><div data-rnw-int-class="180075___573_" tabindex="0" class="css-1dbjc4n r-1awozwy r-42olwf r-z2wwpe r-rs99b7 r-1bnj018 r-1loqt21 r-18u37iz r-18kxxzh r-mabqd8 r-1777fci r-1ny4l3l r-mk0yit r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><svg viewBox="0 0 24 24" fill="none" preserveAspectRatio="xMidYMid meet" data-rnw-int-class="180076___574-48044_" class="r-h7gdob" style="height:16px;vertical-align:middle;width:16px"><path fill-rule="evenodd" clip-rule="evenodd" d="M10.5 4a6.5 6.5 0 100 13 6.5 6.5 0 000-13zM2 10.5a8.5 8.5 0 1117 0 8.5 8.5 0 01-17 0z" fill="currentColor"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M15.093 15.093a1 1 0 011.414 0l5.2 5.2a1 1 0 01-1.414 1.414l-5.2-5.2a1 1 0 010-1.414z" fill="currentColor"></path></svg><div class="css-1dbjc4n r-16y2uox r-1wbh5a2 r-1jkjb"><div dir="auto" data-rnw-int-class="180077___574-48044_" class="css-901oao css-vcwn7f r-h7gdob r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Search…</div></div></div></div><div data-rnw-media-class="visible__hidden" class="css-1dbjc4n"><div data-rnw-int-class="180078___573_" tabindex="0" class="css-1dbjc4n r-1awozwy r-42olwf r-z2wwpe r-rs99b7 r-1bnj018 r-1loqt21 r-18u37iz r-18kxxzh r-mabqd8 r-1777fci r-1ny4l3l r-mk0yit r-1otgn73 r-1i6wzkk r-lrvibr r-1yvhtrz" style="-webkit-transition-duration:0s;transition-duration:0s"><svg viewBox="0 0 24 24" fill="none" preserveAspectRatio="xMidYMid meet" data-rnw-int-class="180079___574-48044_" class="r-h7gdob" style="height:16px;vertical-align:middle;width:16px"><path fill-rule="evenodd" clip-rule="evenodd" d="M10.5 4a6.5 6.5 0 100 13 6.5 6.5 0 000-13zM2 10.5a8.5 8.5 0 1117 0 8.5 8.5 0 01-17 0z" fill="currentColor"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M15.093 15.093a1 1 0 011.414 0l5.2 5.2a1 1 0 01-1.414 1.414l-5.2-5.2a1 1 0 010-1.414z" fill="currentColor"></path></svg></div></div></div></div></div></div><div data-rnw-media-class="188__187" class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2"><div data-rnw-media-class="hidden__visible_b1430-visible" class="css-1dbjc4n r-1vu8cp1 r-g8m1yf r-13l2t4g r-18u37iz r-17s6mgv" style="width:max(300px, calc((100vw - 910px) / 2 - 0px))"><div class="css-1dbjc4n r-eqz5dr r-puj83k r-1ipicw7"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2"><div data-rnw-media-class="visible__hidden" class="css-1dbjc4n r-14lw9ot r-1d9grui r-qklmqi r-4dj0k7 r-1quu1zo r-18u37iz r-sga3zk r-17s6mgv"><div data-rnw-int-class="180080___573_" tabindex="0" class="css-1dbjc4n r-1awozwy r-1kihuf0 r-42olwf r-z2wwpe r-rs99b7 r-1bnj018 r-1loqt21 r-18u37iz r-18kxxzh r-eu3ka r-1777fci r-1ny4l3l r-mk0yit r-1otgn73 r-1i6wzkk r-lrvibr r-1aockid" style="-webkit-transition-duration:0s;transition-duration:0s"><svg viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" preserveAspectRatio="xMidYMid meet" data-rnw-int-class="180081___574-48044_" class="r-h7gdob" style="height:18px;vertical-align:middle;width:18px"><path d="M18 6L6 18M6 6l12 12"></path></svg></div></div><div data-rnw-media-class="hidden__visible" class="css-1dbjc4n r-1d9grui r-qklmqi r-18u37iz r-sga3zk r-1777fci"><a href="/" data-rnw-int-class="180088____" data-rnw-media-class="__200" class="css-4rbku5 css-1dbjc4n r-1awozwy r-1loqt21 r-18u37iz r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s" data-testid="public.headerHomeLink"><div class="css-1dbjc4n r-1awozwy r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2 r-1h0z5md r-6wscbn"><div class="css-1dbjc4n"><div data-rnw-media-class="hidden__visible" class="css-1dbjc4n"><div class="css-1dbjc4n r-1awozwy r-14lw9ot r-z2wwpe r-1l94q7l r-18u37iz r-eu3ka r-1777fci r-88pszg r-1aockid" style="overflow-x:hidden;overflow-y:hidden"><div class="css-1dbjc4n r-4qtqp9 r-1q9jyb7 r-1oec5bt r-u8s1d" style="height:80px;width:80px"><span class="emj-objects _1f58b" role="img" title="fountain pen" aria-label="fountain pen" style="transform:translate(-50%, -50%) scale(1.25)">🖋</span></div><div class="css-1dbjc4n r-4qtqp9 r-bnwqim" style="height:28.16px;width:28.16px"><span class="emj-objects _1f58b" role="img" title="fountain pen" aria-label="fountain pen" style="transform:translate(-50%, -50%) scale(0.44)">🖋</span></div></div></div><div data-rnw-media-class="visible__hidden" class="css-1dbjc4n"><div class="css-1dbjc4n r-1awozwy r-14lw9ot r-z2wwpe r-1l94q7l r-18u37iz r-1777fci r-88pszg" style="height:24px;overflow-x:hidden;overflow-y:hidden;width:24px"><div class="css-1dbjc4n r-4qtqp9 r-1q9jyb7 r-1oec5bt r-u8s1d" style="height:48px;width:48px"><span class="emj-objects _1f58b" role="img" title="fountain pen" aria-label="fountain pen" style="transform:translate(-50%, -50%) scale(0.75)">🖋</span></div><div class="css-1dbjc4n r-4qtqp9 r-bnwqim" style="height:16.64px;width:16.64px"><span class="emj-objects _1f58b" role="img" title="fountain pen" aria-label="fountain pen" style="transform:translate(-50%, -50%) scale(0.26)">🖋</span></div></div></div></div><div dir="auto" data-rnw-media-class="227__226" class="css-901oao"><span aria-label="Sockpuppet" data-rnw-int-class="180089_243__257-48040_" class="css-901oao css-16my406 css-vcwn7f">Sockpuppet</span></div></div></a><div data-rnw-int-class="180082___573_" tabindex="0" class="css-1dbjc4n r-1awozwy r-1kihuf0 r-42olwf r-z2wwpe r-rs99b7 r-1bnj018 r-1loqt21 r-18u37iz r-18kxxzh r-eu3ka r-1777fci r-1ybube5 r-1ny4l3l r-mk0yit r-1otgn73 r-1i6wzkk r-lrvibr r-1aockid" style="-webkit-transition-duration:0s;transition-duration:0s"><svg viewBox="0 0 24 24" fill="none" preserveAspectRatio="xMidYMid meet" data-rnw-int-class="180083___574-48044_" class="r-h7gdob" style="height:18px;vertical-align:middle;width:18px"><path fill-rule="evenodd" clip-rule="evenodd" d="M10.5 4a6.5 6.5 0 100 13 6.5 6.5 0 000-13zM2 10.5a8.5 8.5 0 1117 0 8.5 8.5 0 01-17 0z" fill="currentColor"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M15.093 15.093a1 1 0 011.414 0l5.2 5.2a1 1 0 01-1.414 1.414l-5.2-5.2a1 1 0 010-1.414z" fill="currentColor"></path></svg></div></div><div class="css-1dbjc4n r-150rngu r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-11yh6sk r-1rnoaur r-1sncvnh"><div class="css-1dbjc4n r-1yzf0co"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/" data-rnw-media-class="1465__1466" data-rnw-int-class="180090____" class="css-4rbku5 css-1dbjc4n r-1awozwy r-14lw9ot r-156hn8l r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-t2oyrt r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Welcome</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/setup-django" data-rnw-media-class="1465__1466" data-rnw-int-class="180091__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Setup</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/quickstart-django" data-rnw-media-class="1465__1466" data-rnw-int-class="180092__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Quick Start</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/reflexes" data-rnw-media-class="1465__1466" data-rnw-int-class="180093__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Reflexes</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/lifecycle" data-rnw-media-class="1465__1466" data-rnw-int-class="180094__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Lifecycle</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/scoping" data-rnw-media-class="1465__1466" data-rnw-int-class="180095__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Scoping</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/persistence" data-rnw-media-class="1465__1466" data-rnw-int-class="180096__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Persistence</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/patterns" data-rnw-media-class="1465__1466" data-rnw-int-class="180097__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Useful Patterns</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/events" data-rnw-media-class="1465__1466" data-rnw-int-class="180098__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Working with Events</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/working-with-form" data-rnw-media-class="1465__1466" data-rnw-int-class="180099__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Working with Forms</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/security" data-rnw-media-class="1465__1466" data-rnw-int-class="180100__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Security &amp; Authentication</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><a href="/troubleshooting" data-rnw-media-class="1465__1466" data-rnw-int-class="180101__1467__" class="css-4rbku5 css-1dbjc4n r-1awozwy r-42olwf r-rs99b7 r-1loqt21 r-18u37iz r-15ysp7h r-ymttw5 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-5njf8e"><div dir="auto" class="css-901oao r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Troubleshooting</div></div><div class="css-1dbjc4n r-1awozwy r-18u37iz"></div></a></div></div></div></div></div><div class="css-1dbjc4n r-10ptun7 r-bnwqim r-5dsqua r-13qz1uu r-184en5c" style="background-image:linear-gradient(3.141592653589793rad,#F5F7F900,#F5F7F9)"></div><a href="https://www.gitbook.com/?utm_source=content&amp;utm_medium=trademark&amp;utm_campaign=-M7RbxeoKTD04ZBTrmC5" data-rnw-int-class="180084___1481-48050_" class="css-4rbku5 css-1dbjc4n r-1uwl36a r-z2wwpe r-1rasi3h r-1loqt21 r-18u37iz r-1fdo3w0 r-1mnahxq r-ymttw5 r-5njf8e r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><svg viewBox="0 0 512 512" fill="none" preserveAspectRatio="xMidYMid meet" class="r-eu3ka r-1aockid" style="vertical-align:middle"><path fill-rule="evenodd" clip-rule="evenodd" d="M230.434 379.554c8.259 0 14.978 6.719 14.978 14.974 0 8.256-6.719 14.974-14.978 14.974-8.255 0-14.974-6.718-14.974-14.974 0-8.255 6.719-14.974 14.974-14.974zm235.189-92.758c-8.259 0-14.978-6.719-14.978-14.974 0-8.259 6.719-14.978 14.978-14.978 8.255 0 14.974 6.719 14.974 14.978 0 8.255-6.719 14.974-14.974 14.974zm0-61.351c-25.571 0-46.377 20.805-46.377 46.377 0 4.979.827 9.938 2.46 14.757L268.502 368.13c-8.704-12.543-22.812-19.979-38.068-19.979-17.676 0-33.791 10.113-41.586 25.924L51.211 301.514c-14.54-7.646-25.425-31.595-24.27-53.392.598-11.371 4.53-20.196 10.511-23.604 3.8-2.157 8.37-1.968 13.214.57l.92.485c36.464 19.212 155.822 82.079 160.844 84.413 7.757 3.586 12.069 5.041 25.279-1.222l246.723-128.317c3.615-1.365 7.832-4.83 7.832-10.091 0-7.3-7.546-10.177-7.568-10.177-14.026-6.729-35.601-16.827-56.639-26.676-44.965-21.055-95.933-44.919-118.318-56.639-19.323-10.116-34.877-1.59-37.65.135l-5.39 2.667C165.965 129.482 31.154 196.248 23.479 200.917 9.735 209.28 1.224 225.94.122 246.625c-1.722 32.789 15.007 66.969 38.916 79.512l145.536 75.057c3.279 22.709 22.827 39.712 45.86 39.712 25.337 0 45.992-20.425 46.374-45.672l160.292-86.87a46.41 46.41 0 0028.523 9.835c25.571 0 46.377-20.806 46.377-46.377 0-25.572-20.806-46.377-46.377-46.377z" fill="currentColor"></path></svg><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-1qhn6m8"><div dir="auto" data-rnw-int-class="180085___1481-48050_" class="css-901oao r-1rasi3h r-nwxazl">Powered By <span class="css-901oao css-16my406 r-b88u0q">GitBook</span></div></div></a></div></div><div class="css-1dbjc4n r-14lw9ot r-13awgt0"><div class="css-1dbjc4n r-150rngu r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-11yh6sk r-1rnoaur r-1sncvnh"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2 r-8jnfel"><div class="css-1dbjc4n r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2"><div class="css-1dbjc4n r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2 r-1777fci"><div data-rnw-media-class="1452-1457-__1452-1455-" class="css-1dbjc4n r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2"><div class="css-1dbjc4n r-eqz5dr r-1peese0 r-1ygmrgt"><div class="css-1dbjc4n r-18u37iz"><div data-rnw-media-class="1431__1432" class="css-1dbjc4n r-1awozwy r-18u37iz r-17s6mgv"></div><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2"><div dir="auto" data-rnw-media-class="226__224" class="css-901oao r-1nf4jbm r-1xnzce8" data-testid="page.title">Welcome</div></div></div><div data-rnw-media-class="1434__1433" class="css-1dbjc4n r-1wzrnnt"><div class="css-1dbjc4n"><div dir="auto" class="css-901oao r-1rasi3h r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-1xnzce8">Build reactive applications with the Django tooling you already know and love</div></div></div><div data-rnw-media-class="1434__1433" class="css-1dbjc4n r-nzcix3 r-qklmqi r-11c0sde"></div></div><div data-rnw-media-class="1456__1454-127" class="css-1dbjc4n"><div class="css-1dbjc4n r-bnwqim"><div tabindex="0" class="css-1dbjc4n r-1dqbpge r-eu3ka r-1d2f490 r-u8s1d r-zchlnj r-1sdbnja"></div><div data-testid="page.contentEditor" data-slate-editor="true" data-key="c588ad9313b8458d9a993ca82300b113" autoCorrect="on" spellcheck="true" data-gramm="false" style="outline:none;white-space:pre-wrap;word-wrap:break-word"><div data-key="730e97c4603b4331a115ff363cd8de93" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:12px;padding-top:16px"><div data-block-content="730e97c4603b4331a115ff363cd8de93" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><h1 data-rnw-media-class="__" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010" id="what-is-sockpuppet"><div dir="auto" data-rnw-media-class="207__206" class="css-901oao r-1nf4jbm r-fdjqy7 r-1xnzce8"><span data-key="5034101baa0f4a3b94b7303baa196b32"><span data-offset-key="5034101baa0f4a3b94b7303baa196b32:0">What is Sockpuppet?</span></span></div></h1></div></div><div data-key="9d5f7c3fb2004f9f891d508173be5e61" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:16px;padding-top:4px"><div data-block-content="9d5f7c3fb2004f9f891d508173be5e61" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="c4b651d536a74ec4b0bf770e440ad9d1"><strong data-slate-leaf="true" data-offset-key="c4b651d536a74ec4b0bf770e440ad9d1:0" class="r-b88u0q">Sockpuppet is a new way to craft modern, reactive web interfaces with Django.</strong></span></div></div></div><div data-key="944ad8b11d4041f981d23caa83d4ef80" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:16px;padding-top:4px"><div data-block-content="944ad8b11d4041f981d23caa83d4ef80" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="40a4c615320e40ad8be4effef0c31e82"><span data-offset-key="40a4c615320e40ad8be4effef0c31e82:0">We extend the capabilities of both </span></span><a href="https://www.djangoproject.com" data-rnw-int-class="180122____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="0e1c7fd17af944ad837685d6d983d77e" data-rnw-int-class="180123_257-48040_259-48041-237__"><span data-key="7d11ce950b6746d6acbc86e98001d57b"><span data-offset-key="7d11ce950b6746d6acbc86e98001d57b:0">Django</span></span></span></a><span data-key="e46a602b7bbe40568761131fa3ef2061"><span data-offset-key="e46a602b7bbe40568761131fa3ef2061:0"> and </span></span><a href="https://stimulusjs.org" data-rnw-int-class="180124____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="4ddeb68607374359b9045087e29fc68b" data-rnw-int-class="180125_257-48040_259-48041-237__"><span data-key="0a050e11ea534a5d9b0109fed41ba82c"><span data-offset-key="0a050e11ea534a5d9b0109fed41ba82c:0">Stimulus</span></span></span></a><span data-key="cabc557f9ba543a88895ecde145230b1"><span data-offset-key="cabc557f9ba543a88895ecde145230b1:0"> by intercepting user interactions and passing them to Django over real-time websockets. These interactions are processed by </span><em data-slate-leaf="true" data-offset-key="cabc557f9ba543a88895ecde145230b1:1" class="r-36ujnk">Reflex actions</em><span data-offset-key="cabc557f9ba543a88895ecde145230b1:2"> that change application state. The current page is quickly re-rendered and the changes are sent to the client. The page is then </span></span><a href="https://github.com/patrick-steele-idem/morphdom" data-rnw-int-class="180126____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="e5ef69e5df3d465b8cbc7b37bc1a1e3e" data-rnw-int-class="180127_257-48040_259-48041-237__"><span data-key="3b0917fc6e6948999f99f1a1562a3b38"><span data-offset-key="3b0917fc6e6948999f99f1a1562a3b38:0">morphed</span></span></span></a><span data-key="55850a62c8be4b3ea32baba5ee64cea7"><span data-offset-key="55850a62c8be4b3ea32baba5ee64cea7:0"> to reflect the new application state. This entire round-trip allows us to update the UI in 20-30ms without flicker or expensive page loads.</span></span></div></div></div><div data-key="d16cea25b808453b910623678d228fff" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:16px;padding-top:4px"><div data-block-content="d16cea25b808453b910623678d228fff" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="111ffe24b06d4353a8e84a4b301388c3"><span data-offset-key="111ffe24b06d4353a8e84a4b301388c3:0">This architecture eliminates the complexity imposed by full-stack frontend frameworks without abandoning </span></span><a href="https://www.youtube.com/watch?v=SWEts0rlezA&amp;t=214s" data-rnw-int-class="180128____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="41b7a217427e4dd28f0d38976ccf6378" data-rnw-int-class="180129_257-48040_259-48041-237__"><span data-key="ef3a450e0f2c48d5a5deba18e0c02275"><span data-offset-key="ef3a450e0f2c48d5a5deba18e0c02275:0">high-performance reactive user experiences</span></span></span></a><span data-key="9d62545a03e04053807ed80bc5750f8f"><span data-offset-key="9d62545a03e04053807ed80bc5750f8f:0">. With Sockpuppet, small teams can do big things faster than ever before. We invite you to explore </span><strong data-slate-leaf="true" data-offset-key="9d62545a03e04053807ed80bc5750f8f:1" class="r-b88u0q">a fresh alternative to the Single Page App</strong><span data-offset-key="9d62545a03e04053807ed80bc5750f8f:2"> (SPA).</span></span></div></div></div><div data-key="1a08abbf2e8a4376acdd1bdd786ead51" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:16px;padding-top:4px"><div data-block-content="1a08abbf2e8a4376acdd1bdd786ead51" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="c23b1524b06b41eb8cd7fc4487c85de3"><span data-offset-key="c23b1524b06b41eb8cd7fc4487c85de3:0">We are indebted to the work done in </span></span><a href="https://docs.stimulusreflex.com" data-rnw-int-class="180130____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="9569b464e7d64615809e45f000036897" data-rnw-int-class="180131_257-48040_259-48041-237__"><span data-key="911ebb2c6bc549baa84704e53c3a3f9c"><span data-offset-key="911ebb2c6bc549baa84704e53c3a3f9c:0">StimulusReflex</span></span></span></a><span data-key="1272eb463c664e18b2d7169ae6981799"><span data-offset-key="1272eb463c664e18b2d7169ae6981799:0">. Without them Sockpuppet wouldn&#x27;t exist; it&#x27;s our bigger sibling who prefers to play in the Rails world.</span></span></div></div></div><div data-key="dd90228802d54699b13bc52544337031" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:24px;padding-top:16px"><div data-block-content="dd90228802d54699b13bc52544337031" class="r-1oszu61 r-1vckr1u r-6t5ypu r-119zq30 r-1phboty r-kicko2 r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-116b19x r-11g3r6m r-95jzfe r-bnwqim r-13qz1uu r-417010" style="border-top-color:rgba(38,203,124,1.00);border-right-color:rgba(38,203,124,1.00);border-bottom-color:rgba(38,203,124,1.00);border-left-color:rgba(38,203,124,1.00)"><div class="css-1dbjc4n r-i7aljl r-1vzp2da r-u8s1d" style="top:12px"><svg viewBox="0 0 16 16" fill="none" preserveAspectRatio="xMidYMid meet" style="color:rgba(38,203,124,1.00);height:20px;vertical-align:middle;width:20px"><path fill-rule="evenodd" clip-rule="evenodd" d="M8 1a7 7 0 100 14A7 7 0 008 1zM0 8a8 8 0 1116 0A8 8 0 010 8z" fill="currentColor"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M11.677 6.16l-4.443 4.444a.5.5 0 01-.708 0L4.323 8.4l.707-.707 1.85 1.85 4.09-4.09.707.707z" fill="currentColor"></path></svg></div><div data-key="80872dd0682148b68bebdd087e4d43b9" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:4px;padding-top:4px"><div data-block-content="80872dd0682148b68bebdd087e4d43b9" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="049f8de6f2284e9693b3d3dd6db18f27"><strong data-slate-leaf="true" data-offset-key="049f8de6f2284e9693b3d3dd6db18f27:0" class="r-b88u0q">Get Involved.</strong><span data-offset-key="049f8de6f2284e9693b3d3dd6db18f27:1"> We are stronger together! Please join us on </span></span><a href="https://discord.gg/XveN625" data-rnw-int-class="180132____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="4b4aaf45cfcd43b2aba582ca005266f2" data-rnw-int-class="180133_257-48040_259-48041-237__"><span data-key="f46f1aaef275482ea3995fe7771c7f5e"><span data-offset-key="f46f1aaef275482ea3995fe7771c7f5e:0">Discord</span></span><span data-slate-void="true" data-key="edc1d6d4d7114b1ead95f9e537523fb5"><span><div tabindex="0" class="css-1dbjc4n r-42olwf r-z2wwpe r-d045u9 r-1loqt21 r-xoduu5 r-1pos5eu r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-xoduu5 r-1mlwlqe r-1udh08x r-417010" style="height:20px;width:102px"><div class="css-1dbjc4n r-1niwhzg r-vvn4in r-u6sd8q r-4gszlv r-1p0dtai r-xoduu5 r-1pi2tsx r-1d2f490 r-u8s1d r-zchlnj r-ipm5af r-13qz1uu r-1wyyakw"></div></div></div></span></span><span data-key="7fd1ea21115d471c9360827102c8934c"><span data-offset-key="7fd1ea21115d471c9360827102c8934c:0"><span data-slate-zero-width="z">​</span></span></span></span></a><span data-key="e50c9ea772c247c681eee3cc3e381bd5"><span data-offset-key="e50c9ea772c247c681eee3cc3e381bd5:0"><span data-slate-zero-width="z">​</span></span></span></div></div></div><div data-key="b9897ddbaa6b477ca77056627832538c" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:4px;padding-top:4px"><div data-block-content="b9897ddbaa6b477ca77056627832538c" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="ab1b7c8a65ed42a0855c6189097b1ab0"><span data-offset-key="ab1b7c8a65ed42a0855c6189097b1ab0:0"><span data-slate-zero-width="z">​</span></span></span><a href="https://github.com/jonathan-s/sockpuppet" data-rnw-int-class="180134____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="7feaa819f80849218e4b663aff04ab55" data-rnw-int-class="180135_257-48040_259-48041-237__"><span data-key="a72ac419e1b84c7aa083e18dbeef6a18"><span data-offset-key="a72ac419e1b84c7aa083e18dbeef6a18:0"><span data-slate-zero-width="z">​</span></span></span><span data-slate-void="true" data-key="babc96b4879d4a949b69ef2ec5db098f"><span><div tabindex="0" class="css-1dbjc4n r-42olwf r-z2wwpe r-d045u9 r-1loqt21 r-xoduu5 r-1pos5eu r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-xoduu5 r-1mlwlqe r-1udh08x r-417010" style="height:20px;width:88px"><div class="css-1dbjc4n r-1niwhzg r-vvn4in r-u6sd8q r-4gszlv r-1p0dtai r-xoduu5 r-1pi2tsx r-1d2f490 r-u8s1d r-zchlnj r-ipm5af r-13qz1uu r-1wyyakw"></div></div></div></span></span><span data-key="263ffc95e08b4f388f4b273bbf0b62f8"><span data-offset-key="263ffc95e08b4f388f4b273bbf0b62f8:0"><span data-slate-zero-width="z">​</span></span></span></span></a><span data-key="a21075d1c68440989a9a289c1c0c236f"><span data-offset-key="a21075d1c68440989a9a289c1c0c236f:0"> </span></span><a href="https://github.com/jonathan-s/sockpuppet" data-rnw-int-class="180136____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="b6f0a20cdda543448f06ea37b088ebcc" data-rnw-int-class="180137_257-48040_259-48041-237__"><span data-key="df48f853d326487e88d04a032f9134da"><span data-offset-key="df48f853d326487e88d04a032f9134da:0"><span data-slate-zero-width="z">​</span></span></span><span data-slate-void="true" data-key="13871d8b00ff43df83b2f27c7f78a1e0"><span><div tabindex="0" class="css-1dbjc4n r-42olwf r-z2wwpe r-d045u9 r-1loqt21 r-xoduu5 r-1pos5eu r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-xoduu5 r-1mlwlqe r-1udh08x r-417010" style="height:20px;width:84px"><div class="css-1dbjc4n r-1niwhzg r-vvn4in r-u6sd8q r-4gszlv r-1p0dtai r-xoduu5 r-1pi2tsx r-1d2f490 r-u8s1d r-zchlnj r-ipm5af r-13qz1uu r-1wyyakw"></div></div></div></span></span><span data-key="c2e401a3b9a84d17ab67931b699d5231"><span data-offset-key="c2e401a3b9a84d17ab67931b699d5231:0"><span data-slate-zero-width="z">​</span></span></span></span></a><span data-key="fe71eedcf4bf45a589ee8f59eb7677af"><span data-offset-key="fe71eedcf4bf45a589ee8f59eb7677af:0"> </span></span><a href="https://twitter.com/argparse" data-rnw-int-class="180138____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="4046a37030cd42c4a16de28b9c290f61" data-rnw-int-class="180139_257-48040_259-48041-237__"><span data-key="3f714641a1d24b32a441eb31fe404d39"><span data-offset-key="3f714641a1d24b32a441eb31fe404d39:0"><span data-slate-zero-width="z">​</span></span></span><span data-slate-void="true" data-key="53646a959c574f97bdd2b8b3b10aa209"><span><div tabindex="0" class="css-1dbjc4n r-42olwf r-z2wwpe r-d045u9 r-1loqt21 r-xoduu5 r-1pos5eu r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-xoduu5 r-1mlwlqe r-1udh08x r-417010" style="height:20px;width:156px"><div class="css-1dbjc4n r-1niwhzg r-vvn4in r-u6sd8q r-4gszlv r-1p0dtai r-xoduu5 r-1pi2tsx r-1d2f490 r-u8s1d r-zchlnj r-ipm5af r-13qz1uu r-1wyyakw"></div></div></div></span></span><span data-key="eb51c56f56bc47379b385bc6788fe7e4"><span data-offset-key="eb51c56f56bc47379b385bc6788fe7e4:0"><span data-slate-zero-width="z">​</span></span></span></span></a><span data-key="fa9e1f0d14fc403690a3265162c82ced"><span data-offset-key="fa9e1f0d14fc403690a3265162c82ced:0"><span data-slate-zero-width="z">​</span></span></span></div></div></div></div></div><div class="css-1dbjc4n r-1aerykh r-5kkj8d r-11c0sde r-95jzfe"><div data-key="57f26853e6544f1aaab8377baa396368" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-95jzfe r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:12px"><div data-block-content="57f26853e6544f1aaab8377baa396368" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><h1 data-rnw-media-class="__" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010" id="why-should-i-use-sockpuppet"><div dir="auto" data-rnw-media-class="207__206" class="css-901oao r-1nf4jbm r-fdjqy7 r-1xnzce8"><span data-key="d51b5bbefcee4f5b893b3be83d045487"><span data-offset-key="d51b5bbefcee4f5b893b3be83d045487:0">Why should I use Sockpuppet?</span></span></div></h1></div></div></div><div data-key="4b316a45173649728eeeed2805cafc80" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="4b316a45173649728eeeed2805cafc80" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="d991e4dd2ef84d5b8d4e5ab247c865c7"><span data-offset-key="d991e4dd2ef84d5b8d4e5ab247c865c7:0">Wouldn&#x27;t it be great if you could </span><strong data-slate-leaf="true" data-offset-key="d991e4dd2ef84d5b8d4e5ab247c865c7:1" class="r-b88u0q">focus on your product</strong><span data-offset-key="d991e4dd2ef84d5b8d4e5ab247c865c7:2"> instead of the technical noise introduced by modern JavaScript? With Sockpuppet, you&#x27;ll </span><strong data-slate-leaf="true" data-offset-key="d991e4dd2ef84d5b8d4e5ab247c865c7:3" class="r-b88u0q">ship projects faster, with smaller teams</strong><span data-offset-key="d991e4dd2ef84d5b8d4e5ab247c865c7:4"> and re-discover the joy of programming.</span></span></div></div></div><div data-key="f4004546088d40f1a5fb89087b493ffb" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:12px;padding-top:8px"><div data-block-content="f4004546088d40f1a5fb89087b493ffb" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><h2 data-rnw-media-class="__" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010" id="goals"><div dir="auto" data-rnw-media-class="208__207" class="css-901oao r-1nf4jbm r-fdjqy7 r-1xnzce8"><span data-key="8ca88afecf7c4442ad339a015631a1f5"><span data-offset-key="8ca88afecf7c4442ad339a015631a1f5:0">Goals</span></span></div></h2></div></div><ul class="css-4rbku5 r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-95jzfe r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:24px"><div data-key="64483f5425824477af981f338da4c982" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:4px;padding-top:0px"><div data-block-content="64483f5425824477af981f338da4c982" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div contenteditable="false" class="r-1awozwy r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-18u37iz r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1m04atk r-1pyaxff r-bnwqim r-417010" style="height:24px"><div class="css-1dbjc4n r-1awozwy r-1vfwqja r-1dw0ulf r-z2wwpe r-rs99b7 r-1loqt21 r-1777fci" style="height:18px;width:18px"><svg viewBox="0 0 16 16" fill="none" preserveAspectRatio="xMidYMid meet" class="r-jwli3a r-5cpxsl" style="height:16.2px;vertical-align:middle;width:16.2px"><path fill-rule="evenodd" clip-rule="evenodd" d="M5.72 11.833l8.826-8.836.708.706-9.18 9.19a.5.5 0 01-.707.001l-4.37-4.36.706-.708 4.016 4.007z" fill="currentColor"></path></svg></div></div><div class="css-1dbjc4n r-6koalj r-13awgt0 r-18u37iz"><div class="css-1dbjc4n r-13awgt0"><div data-key="47d0850bd2d3412b84da0d6fe5469733" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:0px;padding-top:0px"><div data-block-content="47d0850bd2d3412b84da0d6fe5469733" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="da28efd401604914956938c9af351bee"><span data-offset-key="da28efd401604914956938c9af351bee:0">Enable small teams to do big things, faster 🏃🏽‍♀️</span></span></div></div></div></div></div></div></div><div data-key="555f3d8cbe6d46a58bfae81e122a5082" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:4px;padding-top:4px"><div data-block-content="555f3d8cbe6d46a58bfae81e122a5082" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div contenteditable="false" class="r-1awozwy r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-18u37iz r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1m04atk r-1pyaxff r-bnwqim r-417010" style="height:24px"><div class="css-1dbjc4n r-1awozwy r-1vfwqja r-1dw0ulf r-z2wwpe r-rs99b7 r-1loqt21 r-1777fci" style="height:18px;width:18px"><svg viewBox="0 0 16 16" fill="none" preserveAspectRatio="xMidYMid meet" class="r-jwli3a r-5cpxsl" style="height:16.2px;vertical-align:middle;width:16.2px"><path fill-rule="evenodd" clip-rule="evenodd" d="M5.72 11.833l8.826-8.836.708.706-9.18 9.19a.5.5 0 01-.707.001l-4.37-4.36.706-.708 4.016 4.007z" fill="currentColor"></path></svg></div></div><div class="css-1dbjc4n r-6koalj r-13awgt0 r-18u37iz"><div class="css-1dbjc4n r-13awgt0"><div data-key="2af4dcdafa504a6284d0412a6ccc02a2" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:0px;padding-top:0px"><div data-block-content="2af4dcdafa504a6284d0412a6ccc02a2" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="59251faa82d54b32970bde62382b852a"><span data-offset-key="59251faa82d54b32970bde62382b852a:0">Increase developer happiness ❤️❤️❤️</span></span></div></div></div></div></div></div></div><div data-key="d2e6ab64c0014a87a37aae8c3596c3cd" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:4px;padding-top:4px"><div data-block-content="d2e6ab64c0014a87a37aae8c3596c3cd" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div contenteditable="false" class="r-1awozwy r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-18u37iz r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1m04atk r-1pyaxff r-bnwqim r-417010" style="height:24px"><div class="css-1dbjc4n r-1awozwy r-1vfwqja r-1dw0ulf r-z2wwpe r-rs99b7 r-1loqt21 r-1777fci" style="height:18px;width:18px"><svg viewBox="0 0 16 16" fill="none" preserveAspectRatio="xMidYMid meet" class="r-jwli3a r-5cpxsl" style="height:16.2px;vertical-align:middle;width:16.2px"><path fill-rule="evenodd" clip-rule="evenodd" d="M5.72 11.833l8.826-8.836.708.706-9.18 9.19a.5.5 0 01-.707.001l-4.37-4.36.706-.708 4.016 4.007z" fill="currentColor"></path></svg></div></div><div class="css-1dbjc4n r-6koalj r-13awgt0 r-18u37iz"><div class="css-1dbjc4n r-13awgt0"><div data-key="1efeb2917993447c8dcee4b44b54e6e5" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:0px;padding-top:0px"><div data-block-content="1efeb2917993447c8dcee4b44b54e6e5" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="cc6b7b5d31104cc3932da761a28a0618"><span data-offset-key="cc6b7b5d31104cc3932da761a28a0618:0">Facilitate simple, concise, and clear code 🤸</span></span></div></div></div></div></div></div></div><div data-key="3beff727b82349c390ed59f3e3cab975" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:0px;padding-top:4px"><div data-block-content="3beff727b82349c390ed59f3e3cab975" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div contenteditable="false" class="r-1awozwy r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-18u37iz r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1m04atk r-1pyaxff r-bnwqim r-417010" style="height:24px"><div class="css-1dbjc4n r-1awozwy r-1vfwqja r-1dw0ulf r-z2wwpe r-rs99b7 r-1loqt21 r-1777fci" style="height:18px;width:18px"><svg viewBox="0 0 16 16" fill="none" preserveAspectRatio="xMidYMid meet" class="r-jwli3a r-5cpxsl" style="height:16.2px;vertical-align:middle;width:16.2px"><path fill-rule="evenodd" clip-rule="evenodd" d="M5.72 11.833l8.826-8.836.708.706-9.18 9.19a.5.5 0 01-.707.001l-4.37-4.36.706-.708 4.016 4.007z" fill="currentColor"></path></svg></div></div><div class="css-1dbjc4n r-6koalj r-13awgt0 r-18u37iz"><div class="css-1dbjc4n r-13awgt0"><div data-key="b12796923a1745fa9230f8a55c6e1cf4" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:0px;padding-top:0px"><div data-block-content="b12796923a1745fa9230f8a55c6e1cf4" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="0d62b7984cbe46cb80f6348823450868"><span data-offset-key="0d62b7984cbe46cb80f6348823450868:0">Integrate seamlessly with Django 🚝</span></span></div></div></div></div></div></div></div></ul><div class="css-1dbjc4n r-1aerykh r-5kkj8d r-11c0sde r-95jzfe"><div data-key="3f4a2d0f097c4da89dc8cb755636dfab" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-95jzfe r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:12px"><div data-block-content="3f4a2d0f097c4da89dc8cb755636dfab" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><h1 data-rnw-media-class="__" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010" id="build-the-next-twitter-in-just-9-minutes-or-less"><div dir="auto" data-rnw-media-class="207__206" class="css-901oao r-1nf4jbm r-fdjqy7 r-1xnzce8"><span data-key="a492b6031d4e41cab34c7440b4eb84af"><span data-offset-key="a492b6031d4e41cab34c7440b4eb84af:0">Build the next Twitter in just 9 minutes (or less) 😉</span></span></div></h1></div></div></div><div data-key="d0f9ff05d4394532870890628363c288" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="d0f9ff05d4394532870890628363c288" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="674f90d51fb54922b990292aa1a56f8c"><span data-offset-key="674f90d51fb54922b990292aa1a56f8c:0">Our friends at StimulusReflex proves that you can build things fast.</span></span></div></div></div><div data-slate-void="true" data-key="7e9bfc6cb294443f85bf2f6b87cdba8a"><div><div data-key="7e9bfc6cb294443f85bf2f6b87cdba8a" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:12px;padding-top:12px"><div data-block-content="7e9bfc6cb294443f85bf2f6b87cdba8a" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div class="css-1dbjc4n r-bnwqim"><div><div><div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.25%;"><iframe src="https://cdn.iframe.ly/UXgOq2b" style="top: 0; left: 0; width: 100%; height: 100%; position: absolute; border: 0;" allowfullscreen scrolling="no" allow="accelerometer *; clipboard-write *; encrypted-media *; gyroscope *; picture-in-picture *;"></iframe></div></div></div></div></div></div></div></div><div class="css-1dbjc4n r-1aerykh r-5kkj8d r-11c0sde r-95jzfe"><div data-key="9f45ce312e114fcca5732010fc75c3b2" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-95jzfe r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:12px"><div data-block-content="9f45ce312e114fcca5732010fc75c3b2" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><h1 data-rnw-media-class="__" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010" id="how-we-got-here"><div dir="auto" data-rnw-media-class="207__206" class="css-901oao r-1nf4jbm r-fdjqy7 r-1xnzce8"><span data-key="96b2921b5f4940edb6b7e8e35802b6cd"><span data-offset-key="96b2921b5f4940edb6b7e8e35802b6cd:0">How we got here</span></span></div></h1></div></div></div><div data-key="ef0b3d0c1cb64561af347ed26cfa25c6" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="ef0b3d0c1cb64561af347ed26cfa25c6" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="674079bbbb73479b975c0a9dc4be700f"><span data-offset-key="674079bbbb73479b975c0a9dc4be700f:0">Applications nowadays pursue native UI speeds which spawned a new breed of increasingly complex technologies. Modern </span><strong data-slate-leaf="true" data-offset-key="674079bbbb73479b975c0a9dc4be700f:1" class="r-b88u0q">Single Page Apps</strong><span data-offset-key="674079bbbb73479b975c0a9dc4be700f:2"> have pushed much of the server&#x27;s responsibilities to the client. Unfortunately, this new approach trades </span><em data-slate-leaf="true" data-offset-key="674079bbbb73479b975c0a9dc4be700f:3" class="r-36ujnk">a developer experience</em><span data-offset-key="674079bbbb73479b975c0a9dc4be700f:4"> that was once </span><strong data-slate-leaf="true" data-offset-key="674079bbbb73479b975c0a9dc4be700f:5" class="r-b88u0q">fun and productive</strong><span data-offset-key="674079bbbb73479b975c0a9dc4be700f:6"> for an alternative of high complexity and only marginal gains.</span></span></div></div></div><div data-key="1fb3e0a80a534de3a2d6e627ebd63c37" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="1fb3e0a80a534de3a2d6e627ebd63c37" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="d2e141f1a119466faf980a67e6ff8a6c"><strong data-slate-leaf="true" data-offset-key="d2e141f1a119466faf980a67e6ff8a6c:0" class="r-b88u0q">There must be a better way.</strong></span></div></div></div><div class="css-1dbjc4n r-1aerykh r-5kkj8d r-11c0sde r-95jzfe"><div data-key="05ea652bf0c84c9989c8793f456e98d6" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-95jzfe r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:12px"><div data-block-content="05ea652bf0c84c9989c8793f456e98d6" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><h1 data-rnw-media-class="__" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010" id="the-revolution-begins"><div dir="auto" data-rnw-media-class="207__206" class="css-901oao r-1nf4jbm r-fdjqy7 r-1xnzce8"><span data-key="3fa37dbb50144dc4a47a92f352f2595c"><span data-offset-key="3fa37dbb50144dc4a47a92f352f2595c:0">The revolution begins</span></span></div></h1></div></div></div><div data-key="962dc0fd68c6439f947b5fe4795755fa" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="962dc0fd68c6439f947b5fe4795755fa" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="e0a6d762e3ec44e8b93c4d792fb8525f"><span data-offset-key="e0a6d762e3ec44e8b93c4d792fb8525f:0">In his 2018 ElixirConf keynote, </span></span><a href="https://twitter.com/chris_mccord" data-rnw-int-class="180140____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="e9bb9d5917f746648218363822ad4782" data-rnw-int-class="180141_257-48040_259-48041-237__"><span data-key="e4a4b33264904a55a53ae4a1f0764660"><span data-offset-key="e4a4b33264904a55a53ae4a1f0764660:0">Chris McCord</span></span></span></a><span data-key="db72ec70e24542d4adba635746822630"><span data-offset-key="db72ec70e24542d4adba635746822630:0"> </span><em data-slate-leaf="true" data-offset-key="db72ec70e24542d4adba635746822630:1" class="r-36ujnk">(creator of the</em><span data-offset-key="db72ec70e24542d4adba635746822630:2"> </span></span><a href="http://www.phoenixframework.org" data-rnw-int-class="180142____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="f9126b371ac94480b9cb035445fe55f6" data-rnw-int-class="180143_257-48040_259-48041-237__"><span data-key="ac416565eed0435dbddf7a4624598c48"><em data-slate-leaf="true" data-offset-key="ac416565eed0435dbddf7a4624598c48:0" class="r-36ujnk">Phoenix</em></span></span></a><span data-key="b1283cdf759d4e7b950327d98cc771d1"><span data-offset-key="b1283cdf759d4e7b950327d98cc771d1:0"> </span><em data-slate-leaf="true" data-offset-key="b1283cdf759d4e7b950327d98cc771d1:1" class="r-36ujnk">framework for</em><span data-offset-key="b1283cdf759d4e7b950327d98cc771d1:2"> </span></span><a href="https://elixir-lang.org" data-rnw-int-class="180144____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="04f143530bbc4d15822253786a105b7c" data-rnw-int-class="180145_257-48040_259-48041-237__"><span data-key="9ccbea7be54842d49b096e4d9fb7473f"><em data-slate-leaf="true" data-offset-key="9ccbea7be54842d49b096e4d9fb7473f:0" class="r-36ujnk">Elixir</em></span></span></a><span data-key="3fc2b3a318fb460aa73d39e6e90644c3"><em data-slate-leaf="true" data-offset-key="3fc2b3a318fb460aa73d39e6e90644c3:0" class="r-36ujnk">)</em><span data-offset-key="3fc2b3a318fb460aa73d39e6e90644c3:1"> introduced </span></span><a href="https://github.com/phoenixframework/phoenix_live_view" data-rnw-int-class="180146____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="438cdd7388c8418aa5c70fc1dac8e8f1" data-rnw-int-class="180147_257-48040_259-48041-237__"><span data-key="d1039207fb574adca14a946e4fc85c30"><span data-offset-key="d1039207fb574adca14a946e4fc85c30:0">LiveView</span></span></span></a><span data-key="f6504b7bef514175bc94e51c315df10c"><span data-offset-key="f6504b7bef514175bc94e51c315df10c:0">, an alternative to the SPA. His </span></span><a href="https://www.youtube.com/watch?v=8xJzHq8ru0M" data-rnw-int-class="180148____" class="css-4rbku5 css-1dbjc4n r-1loqt21 r-1471scf r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><span data-key="5beeb1de3f1b4e82847f34454bbb1bd6" data-rnw-int-class="180149_257-48040_259-48041-237__"><span data-key="726d48d155ab429ab6e1c45e7afcf82a"><span data-offset-key="726d48d155ab429ab6e1c45e7afcf82a:0">presentation</span></span></span></a><span data-key="538da768a2714010b2f38a5d5831a2e7"><span data-offset-key="538da768a2714010b2f38a5d5831a2e7:0"> captures the same promise and excitement that Rails had in the early days.</span></span></div></div></div><div data-key="c936550daa9a4448afa70550a759ecbd" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="c936550daa9a4448afa70550a759ecbd" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="c0012518f7794752b15954af945db05f"><span data-offset-key="c0012518f7794752b15954af945db05f:0">We love Elixir and Phoenix. Elixir hits a sweet spot for people who want Rails-like conventions in a functional language. The community is terrific, but it&#x27;s still small and comparatively niche.</span></span></div></div></div><div data-key="cc0c2406d4404b52aeec288e14bc2eeb" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="cc0c2406d4404b52aeec288e14bc2eeb" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="92461004ec13449e97e82e45fc8f809d"><span data-offset-key="92461004ec13449e97e82e45fc8f809d:0">Also, we just really enjoy using </span><strong data-slate-leaf="true" data-offset-key="92461004ec13449e97e82e45fc8f809d:1" class="r-b88u0q">Django</strong><span data-offset-key="92461004ec13449e97e82e45fc8f809d:2">.</span></span></div></div></div><div data-key="8f5a0b5e87d04bdd8ec9ac7a8b4d12d5" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="8f5a0b5e87d04bdd8ec9ac7a8b4d12d5" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="f93d42f2ebc04763a3f72c9c135b619e"><span data-offset-key="f93d42f2ebc04763a3f72c9c135b619e:0">Sockpuppet was originally inspired by StimulusReflex which was inspired by LiveView, but we are charting our own course together with StimulusReflex. Our goal has always been to make building modern apps with Django the most productive and enjoyable option available. We want to inspire our friends working with other tools and technologies to evaluate how concepts like Sockpuppet could work in their ecosystems and communities.</span></span></div></div></div><div class="css-1dbjc4n r-1aerykh r-5kkj8d r-11c0sde r-95jzfe"><div data-key="c7d0964215b6476ca0599c4ff7665313" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-95jzfe r-1f1sjgu r-bnwqim r-417010" style="padding-bottom:12px"><div data-block-content="c7d0964215b6476ca0599c4ff7665313" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><h1 data-rnw-media-class="__" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010" id="architecture"><div dir="auto" data-rnw-media-class="207__206" class="css-901oao r-1nf4jbm r-fdjqy7 r-1xnzce8"><span data-key="6df25777f015409f8ad565c88adafcda"><span data-offset-key="6df25777f015409f8ad565c88adafcda:0">Architecture</span></span></div></h1></div></div></div><div data-key="f5e33ad6029e49d89733f962a9ca03e3" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="f5e33ad6029e49d89733f962a9ca03e3" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="e179bf7142be41cab68caaab78f20857"><span data-offset-key="e179bf7142be41cab68caaab78f20857:0">So what is happening behind the scenes here? Sockpuppet works in three layers.</span></span></div></div></div><div data-key="8caa4262d067420f8f1c6c938d4b6c0a" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="8caa4262d067420f8f1c6c938d4b6c0a" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="a21ea639467a49c8b37098b9d046632f"><span data-offset-key="a21ea639467a49c8b37098b9d046632f:0">It uses JavaScript; The JavaScript is re-used from StimulusReflex, which in itself is built upon StimulusJS. The JavaScript in StimulusReflex also uses something called </span><code data-slate-leaf="true" data-offset-key="a21ea639467a49c8b37098b9d046632f:1" class="r-1vckr1u r-z2wwpe r-uibjmv r-m2pi6t r-1hvjb8t">morphdom</code><span data-offset-key="a21ea639467a49c8b37098b9d046632f:2"> which has the responsibility of modifying the DOM. The JavaScript layer ensures that the data is being sent to the server layer through websockets. When a message is received from the server layer it will re-render the dom according to the server-side instructions.</span></span></div></div></div><div data-key="45b4802980af439a9df6a17d2018bdc2" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="45b4802980af439a9df6a17d2018bdc2" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="29eef47057404c86ba7bf3ea8bc26d74"><span data-offset-key="29eef47057404c86ba7bf3ea8bc26d74:0">The HTML layer has the responsibility of defining where and how a &quot;Reflex&quot; is going to be triggered. Ie, a Reflex could be triggered by a browser event or the click of a button. When building more complex applications the HTML layer may also be used to store state so that this state is accessible when doing some interactivity in a stimulus controller.</span></span></div></div></div><div data-key="f9b00334d0794968910fd54f8001bb42" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1mlwlqe r-eqz5dr r-1q142lx r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-1l7z4oj r-1f1sjgu r-bnwqim r-417010" style="padding-top:4px"><div data-block-content="f9b00334d0794968910fd54f8001bb42" class="r-1oszu61 r-1xc7w19 r-1phboty r-1yadl64 r-deolkf r-6koalj r-1ro0kt6 r-eqz5dr r-16y2uox r-1wbh5a2 r-crgep1 r-ifefl9 r-bcqeeo r-t60dpp r-bnwqim r-417010"><div dir="auto" class="css-901oao r-1nf4jbm r-gg6oyi r-ubezar r-16dba41 r-135wba7 r-fdjqy7 r-1xnzce8"><span data-key="13c0106ced0e478a834dd0ba015fcab2"><span data-offset-key="13c0106ced0e478a834dd0ba015fcab2:0">The last layer is the server layer. This is where a Reflex class is defined. The Reflex knows what path and template was received and will re-render that template to contain any new information defined in the Reflex. The Reflex could also make database queries or initiate long-running processes. Once the template is re-rendered it will send it back to the frontend where JavaScript will modify the DOM to update everything.</span></span></div></div></div></div><div tabindex="0" class="css-1dbjc4n r-1p5i0ed r-1dqbpge r-1472mwg r-1d2f490 r-u8s1d r-zchlnj"></div></div><div data-rnw-media-class="__187_b910-188" class="css-1dbjc4n r-11c0sde"><a href="/setup-django" data-rnw-media-class="__" data-rnw-int-class="180102___832-48065_" class="css-4rbku5 css-1dbjc4n r-1awozwy r-14lw9ot r-190qawg r-z2wwpe r-rs99b7 r-4dj0k7 r-1loqt21 r-1quu1zo r-1ro0kt6 r-18u37iz r-16y2uox r-1wbh5a2 r-nsbfu8 r-1otgn73 r-1i6wzkk r-lrvibr" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2"><div class="css-1dbjc4n"><div dir="auto" class="css-901oao r-1rasi3h r-gg6oyi r-1enofrn r-16dba41 r-14yzgew">Next</div></div><div dir="auto" data-rnw-int-class="180103___257-48040_" class="css-901oao css-vcwn7f r-1nf4jbm r-gg6oyi r-ubezar r-majxgm r-135wba7">Setup</div></div><div class="css-1dbjc4n r-1ow6zhx"><svg viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" preserveAspectRatio="xMidYMid meet" data-rnw-int-class="180104__257-48040__" class="r-1rasi3h r-1472mwg" style="vertical-align:middle;width:24px"><path d="M5 12h14M12 5l7 7-7 7"></path></svg></div></a></div><div class="css-1dbjc4n r-1yv4afn r-5kkj8d r-11c0sde r-1ygmrgt"><div class="css-1dbjc4n r-1awozwy r-18u37iz"><div class="css-1dbjc4n r-1ro0kt6 r-16y2uox r-1wbh5a2"><div dir="auto" class="css-901oao r-1rasi3h r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Last modified <span aria-label="2020-12-26 11:38 UTC" class="css-901oao css-16my406">9mo ago</span></div></div></div></div></div></div></div><div data-rnw-media-class="hidden__1kbfcbz_b1430-hidden" class="css-1dbjc4n r-k200y r-pw2am6 r-icyqz7 r-1mkpi1y r-1rnoaur r-1h4fu65 r-gtdqiz r-eqo98v"><div class="css-1dbjc4n r-dvzwsg r-1ljd8xs r-1peese0 r-hu79xy"><div class="css-1dbjc4n r-1mdbw0j r-wk8lta"><div data-rnw-int-class="180105____" tabindex="0" class="css-1dbjc4n r-1awozwy r-1loqt21 r-18u37iz r-dnmrzs r-1guathk r-oyd9sg r-1otgn73 r-1i6wzkk r-lrvibr r-7xmw5f" style="-webkit-transition-duration:0s;transition-duration:0s"><div class="css-1dbjc4n r-1kb76zh"><svg viewBox="0 0 16 16" fill="none" preserveAspectRatio="xMidYMid meet" data-rnw-int-class="180106___257-48040_" class="r-1rasi3h r-10ptun7" style="vertical-align:middle;width:16px"><path d="M14.11 6.6l-.16-.09c-.042.343-.13.68-.26 1A3 3 0 0115 10a3 3 0 01-3 3H8a3 3 0 010-6h.82A3 3 0 009 6H8a4 4 0 000 8h4a4 4 0 002.11-7.4z" fill="currentColor"></path><path d="M1.89 9.4l.16.09c.042-.343.13-.68.26-1A3 3 0 011 6a3 3 0 013-3h4a3 3 0 110 6h-.82A3 3 0 007 10h1a4 4 0 000-8H4a4 4 0 00-2.11 7.4z" fill="currentColor"></path></svg></div><div dir="auto" data-rnw-int-class="180107___257-48040_" class="css-901oao css-vcwn7f r-1bnj018 r-1ro0kt6 r-16y2uox r-1wbh5a2 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Copy link</div></div></div></div><div class="css-1dbjc4n r-dvzwsg r-1ljd8xs r-146iojx"><div class="css-1dbjc4n r-1awozwy r-18u37iz r-5oul0u r-1guathk"><svg viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" preserveAspectRatio="xMidYMid meet" class="r-1rasi3h r-10ptun7" style="vertical-align:middle;width:16px"><path d="M21 10H7M21 6H3M21 14H3M21 18H7"></path></svg><div dir="auto" class="css-901oao r-1rasi3h r-gg6oyi r-1enofrn r-b88u0q r-19r33im r-14yzgew r-1jkjb r-tsynxw">Contents</div></div><a href="/#what-is-sockpuppet" data-rnw-int-class="180108____" class="css-4rbku5 css-1dbjc4n r-855088 r-dwliz8 r-1loqt21 r-18u37iz r-lqms97 r-dnmrzs r-iphfwy r-1guathk r-1h8ys4a r-1otgn73 r-1i6wzkk r-lrvibr r-7xmw5f" style="-webkit-transition-duration:0s;transition-duration:0s"><div dir="auto" data-rnw-int-class="180109___257-48040_" class="css-901oao css-vcwn7f r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">What is Sockpuppet?</div></a><a href="/#why-should-i-use-sockpuppet" data-rnw-int-class="180110____" class="css-4rbku5 css-1dbjc4n r-855088 r-dwliz8 r-1loqt21 r-18u37iz r-lqms97 r-dnmrzs r-iphfwy r-1guathk r-1h8ys4a r-1otgn73 r-1i6wzkk r-lrvibr r-7xmw5f" style="-webkit-transition-duration:0s;transition-duration:0s"><div dir="auto" data-rnw-int-class="180111___257-48040_" class="css-901oao css-vcwn7f r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Why should I use Sockpuppet?</div></a><a href="/#goals" data-rnw-int-class="180112____" class="css-4rbku5 css-1dbjc4n r-855088 r-dwliz8 r-1loqt21 r-18u37iz r-lqms97 r-dnmrzs r-iphfwy r-1guathk r-1h8ys4a r-1otgn73 r-1i6wzkk r-lrvibr r-7xmw5f" style="-webkit-transition-duration:0s;transition-duration:0s"><div dir="auto" data-rnw-int-class="180113___257-48040_" class="css-901oao css-vcwn7f r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb r-1jkjb">Goals</div></a><a href="/#build-the-next-twitter-in-just-9-minutes-or-less" data-rnw-int-class="180114____" class="css-4rbku5 css-1dbjc4n r-855088 r-dwliz8 r-1loqt21 r-18u37iz r-lqms97 r-dnmrzs r-iphfwy r-1guathk r-1h8ys4a r-1otgn73 r-1i6wzkk r-lrvibr r-7xmw5f" style="-webkit-transition-duration:0s;transition-duration:0s"><div dir="auto" data-rnw-int-class="180115___257-48040_" class="css-901oao css-vcwn7f r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Build the next Twitter in just 9 minutes (or less) 😉</div></a><a href="/#how-we-got-here" data-rnw-int-class="180116____" class="css-4rbku5 css-1dbjc4n r-855088 r-dwliz8 r-1loqt21 r-18u37iz r-lqms97 r-dnmrzs r-iphfwy r-1guathk r-1h8ys4a r-1otgn73 r-1i6wzkk r-lrvibr r-7xmw5f" style="-webkit-transition-duration:0s;transition-duration:0s"><div dir="auto" data-rnw-int-class="180117___257-48040_" class="css-901oao css-vcwn7f r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">How we got here</div></a><a href="/#the-revolution-begins" data-rnw-int-class="180118____" class="css-4rbku5 css-1dbjc4n r-855088 r-dwliz8 r-1loqt21 r-18u37iz r-lqms97 r-dnmrzs r-iphfwy r-1guathk r-1h8ys4a r-1otgn73 r-1i6wzkk r-lrvibr r-7xmw5f" style="-webkit-transition-duration:0s;transition-duration:0s"><div dir="auto" data-rnw-int-class="180119___257-48040_" class="css-901oao css-vcwn7f r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">The revolution begins</div></a><a href="/#architecture" data-rnw-int-class="180120____" class="css-4rbku5 css-1dbjc4n r-855088 r-dwliz8 r-1loqt21 r-18u37iz r-lqms97 r-dnmrzs r-iphfwy r-1guathk r-1h8ys4a r-1otgn73 r-1i6wzkk r-lrvibr r-7xmw5f" style="-webkit-transition-duration:0s;transition-duration:0s"><div dir="auto" data-rnw-int-class="180121___257-48040_" class="css-901oao css-vcwn7f r-1bnj018 r-gg6oyi r-1b43r93 r-majxgm r-hbpseb">Architecture</div></a></div></div></div></div></div></div></div></div></div></div>
    <script>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</script>
    <script type="module" src="https://app.gitbook.com/public/app/public-IGO2W5FS.min.js?v=10.0.15-eda761893f18a9c82baefa53b70d3e24fc50bc09-1385309814"></script>
        <script type="text/javascript" src="https://cdn.iframe.ly/embed.js" async></script>
        <script type="text/javascript" src="https://cdn.polyfill.io/v2/polyfill.js?features=Intl.~locale.en" crossorigin="anonymous"></script>
    </body>
</html>
